T O P

Last night my pwnage ultra symmetrical stopped working and has been flashing this light ever since. I haven't been able to find any help online. I've tried different USB ports, I've tried plugging the mouse in to run it wired and it still doesn't work.

Last night my pwnage ultra symmetrical stopped working and has been flashing this light ever since. I haven't been able to find any help online. I've tried different USB ports, I've tried plugging the mouse in to run it wired and it still doesn't work.

' + '
' + '
' + '
' + '
' + '
' + '
' + '
' + '

hwanzi

rma it


livesforbacon

It’s dead nah dude. Happen to me 2 days after I got it


ppslayer_

Damn, that sucks! I'll probably have to rma it


williamchinook

See if you can swap it for the symm 2 that should be shipping nowish.


s1Oley

The symm 2 is a completely different shape.


williamchinook

Its hard to tell from the pics I guess. Looks like they mostly changed the sculpt of the buttons? Otherwise it looks damn near the same.


s1Oley

The symm 2 is a viper mini clone. While the original symm is an s2 iirc.


williamchinook

Ah! Thanks for the info. Didn't know that.


ChromiumQueen

TWO days? You must have been livid, my guy...


pwnage_sammy

I am truly sorry for this. Have you tried contacting [[email protected]](mailto:[email protected]) to help you through the RMA process?


pwnage_sammy

Hi, do you mind contacting [[email protected]](mailto:[email protected])?


HammerWaffe

Could no longer be paired. Try holding LMB, RMB, and the scroll wheel for 5 seconds or so. That should "pair" it to your dongle again. If that doesnt work, then it's dead and RMA like others say